Eclipse development setup for CIShell and Sci2

Introduction

This tutorial will be presented in steps, and assumes you already have the most recent version of the Java 7 64-bit 

Preparing Eclipse

Install and Launch Eclipse

The first thing you'll need to do is acquire Eclipse, if you don't already have it. The Eclipse.org website is the official source for these downloads. In this case, we will be installing the latest version, Eclipse Luna 64 bit version. It is recommended to download the Eclipse Standard Package. Make sure you have Java 64-bit JDK in your workstation. Extract the contents of the .zip download, which should consist of a folder called eclipse. Place the folder wherever you would like, change the name if you wish, and then open up eclipse.exe contained in the folder. Eclipse will ask you to select a workspace, so either accept the default location or select a custom directory. When Eclipse opens for the first time, you should see a welcome screen, which you can close.
Install and Configure Eclipse Plugins

EGit

EGit should be included in all Eclipse Standard packages. To double check, you can click on Help->About Eclipse from the Eclipse toolbar. EGit should be one of the plugins listed.
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Maven Integration (m2eclipse)

To install m2eclipse, you'll want to go to Help->Install New Software... from the Eclipse toolbar.
1. In the Work with: field, paste the following URL: http://download.eclipse.org/technology/m2e/releases
2. Click on the Add... button to the right of that field

3. Give a descriptive name to this new repository, such as m2eclipse
4. After fetching data from the repository, a single top level result should appear. Check the box to the left of Maven Integration for Eclipse, then click Next
5. Click Next again, accept the terms of the license agreement, then click Finish
6. Eclipse will now install m2eclipse. It may ask to be restarted - go ahead and agree to that so that the installation can complete 
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Add m2eclipse Connectors

The Maven integration software requires a connector for Git before we can start pulling code and importing projects with Maven. We will now install the connectors.
egit Handler

1. Go to File->Import... from the Eclipse toolbar

2. Select Maven->Check out Maven Projects from SCM and then click Next
3. Near the bottom of this window, where it says Find more SCM connectors in the m2e Marketplace, click the blue link

4. In the window that opens, in the Find: field, type in egit. The first result should be m2e-egit  check the box next to that entry and click Finish
5. After some processing, another window should pop up. The Maven SCM Handler should be checked, so you can just click Next here

6. Click Next on the following screen, then accept the license agreement and click Finish
7. A security warning might pop up, just click OK
8. A dialog will prompt you to restart Eclipse - click Yes
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Download Git -Home
Download Tortoise Git - Home
Download git bash :- git bash command for long paths - Home
Ant-Contrib

In order to build programs like CIShell, additional build steps are sometimes required outside of the usual Maven build process. For these tasks, you'll need to use Ant. In this case, you will need to install the Ant-Contrib library to your local version of Ant.
1. Download and unzip the latest version of Ant-Contrib. Ant-Contrib has not been updated since 2006, so it's a pretty safe bet that this download will be the most recent release: ant-contrib-1.0b3-bin.zip
2. After unzipping, you'll want to move the jar file (ex: ant-contrib-1.0b3.jar) to your ANT_INSTALLATION/lib/ directory. In my case, this was located at plugins/org.apache.ant_<version>/lib inside of my main Eclipse folder

3. Next, you need to add the new jar to Ant's classpath. To do this, go to Window->Preferences->Ant->Runtime->Classpath in Eclipse. Select Ant Home Entries, then click Add External JARs. Now navigate to the ant-contrib jar we imported and select it. A warning might pop up, but just click Yes if that happens.

4. Now click OK to save your preferences, and Ant-Contrib should be ready to go
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Forking the Repositories

1. Fork CIShell repository to your github IU account from the CNS CIShell github IU repository.

2. Fork nwb repository to your github IU account from the CNS nwb github IU repository. 
Pulling Code and Building

Once your Eclipse is fully configured, you can begin the process of pulling source code from the relevant Git repositories.
CIShell

Pulling from the GitHub Repository

To pull and commit changes to the public GitHub repository, you will need a GitHub account. If you want eventually to commit changes and have them added to the main CIShell repository, you'll want to fork it and commit your changes there. Then you can submit a pull request to have your changes integrated to the production branch. For this walkthrough, I'll use my personal fork of CIShell.
1. Git clone the repository https://github.com/<username>/ CIShell.git. You shall need to replace <username> with your username for Git repository.
2. Go to File->Import... on the Eclipse toolbar

3. Select Existing Maven Projects , then click Next
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4. In the Root Directory text box, browse to the git repository you wish to import using the Browse button.
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5. Most developers prefer to append a name to all projects imported from a certain repo. You can do that using the Name template field, as shown. Then click Finish


6. On this next screen with all the green check marks, just click Finish
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7. Tycho builds eclipse plugin with maven. So Eclipse will prompt to install 'Tycho Project Configurators’. Just click 'Next' though the dialogs and accept license agreement. After installation, it will prompt to restart. Click 'Yes'.
[image: image13.png]L eeetes——

Install @ .
Check the items that you wish to install.

Name Version d
[7]@Tycho Project Configurators 080.201409231215  orgsonatype-tycho.m2e feature.
< 1 »
Select All Deselect All
Details

o~

@ <Back [ New> | Finish Cancel




 

8. At this point, Eclipse will pull in all the CIShell projects. Each project should now be managed by Maven and in sync with your Git repository, as shown by the symbols on each project
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9. The parent project is the top level CIShell project, which you can later use to build CIShell with

You now have everything you need to work on the CIShell core in your local development environment, or build CIShell completely.
Building with Maven and Ant
1. In the parent-cishell project’s pom.xml file change value for property tychoVersion to 0.18.1. Save the pom.xml file. You just need to do it once. 
2. Parent CIShell pom.xml location:-
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Double click the pom.xml. Search for tychoVersion tag. 

Change the version from 0.14.1 to 0.18.1 
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3. Right click the parent CIShell project (named parent-cishell in my example), then click Run As->Maven build...
4. In the window that pops up, type clean install into the Goals field. This will perform a Maven clean, followed by a Maven install command

5. Click the Run button. Maven will then go through the CIShell build process, which may take some time

6. After the Maven tasks have completed (you should see BUILD SUCCESS in the console if this is the case), we need to perform the Ant tasks

1. In the parent project, go to deployment/org.cishell.reference.releng/postMavenTasks.xml, right click on it, and go to Run As->Ant Build
2. You will probably see output of the Ant script in the Console, but it should eventually stop with a BUILD SUCCESSFUL message
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Sci2 
Pulling from the GitHub Repository

To pull and commit changes to the public GitHub repository, you will need a GitHub account. If you want eventually to commit changes and have them added to the main CIShell repository, you'll want to fork it and commit your changes there. Then you can submit a pull request to have your changes integrated to the production branch. For this walkthrough, I'll use my personal fork of CIShell.

1. Git clone the repository https://github.com/<username>/ nwb.git. You shall need to replace <username> with your username for Git repository.
2. Go to File->Import... on the Eclipse toolbar

3. Select Existing Maven Projects , then click Next
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4. In the Root Directory text box, browse to the git repository’s trunk folder you wish to import using the Browse button.
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5. Most developers prefer to append a name to all projects imported from a certain repo. You can do that using the Name template field, as shown. Then click Finish
6. Eclipse shall now import the entire NWB trunk repository. It may take it some time.
Building with Maven

1. Right click the parent Sci2 project (named parent-sci2 in my example), then click Run As->Maven build...
2. In the window that pops up, type clean install into the Goals field. This will perform a Maven clean, followed by a Maven install command

3. Click the Run button. This may take some time. If the build process stops with the message BUILD SUCCEEDED in the console, then congrats, you're done. If instead you see ERROR several times, read on

Eclipse Error 
OpenCSV Error

When doing a Maven clean install, you may sometimes encounter this error which prematurely ends the build process:
Maven Build console output 

[ERROR] Cannot resolve project dependencies:

[ERROR] Software being installed: edu.iu.sci2.javaalgorithms.feature.feature.group 1.0.0

[ERROR] Missing requirement: edu.iu.sci2.javaalgorithms.feature.feature.group 1.0.0 requires 'opencsv [2.2.0,2.2.1)' but it could not be found

[ERROR]
A workaround for this issue is to actually go into the project in question (in this case, edu.iu.sci2.javaalgorithms.feature) in your Eclipse workspace and edit the feature.xml file:

1. Open feature.xml in the Eclipse editor

2. Select feature.xml at the bottom to view the raw xml text

3. Find the <plugin ... /> item with an id value of "opencsv" (sometimes "opencsv.source")

4. Change the version value to "0.0.0" - this will pull in the latest version of OpenCSV instead of requiring a specific version

5. Save the file

Now attempt the Maven clean install command again, as described before. 

Maven Build console output 

[ERROR]   Cannot resolve project dependencies:
[ERROR]   Software being installed: edu.iu.sci2.p2 1.0.0
[ERROR]   Missing requirement: edu.iu.sci2.source.feature.feature.group 1.0.0 requires 'opencsv.source [2.2.0,2.2.1)' but it could not be found
[ERROR]   Cannot satisfy dependency: edu.iu.sci2.p2 1.0.0 depends on: edu.iu.sci2.source.feature.feature.group [1.0.0,1.0.1)
A workaround for this issue is to actually go into the project in question (in this case, edu.iu.sci2.source.feature-sci2) in your Eclipse workspace and edit the feature.xml file:

1. Open feature.xml in the Eclipse editor

2. Select feature.xml at the bottom to view the raw xml text

3. Find the <plugin ... /> item with an id value of "opencsv" (sometimes "opencsv.source")

4. Change the version value to "0.0.0" - this will pull in the latest version of OpenCSV instead of requiring a specific version

5. Save the file

Now attempt the Maven clean install command again, as described before. 

Bipartitenet Compilation Error: - Not encountered it since using Eclipse Luna
Some have reported running into this issue, which is more rare but still occasionally pops up when building Sci2:
Maven console output 

[ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:0.14.1:compile (default-compile) on project edu.iu.sci2.visualization.bipartitenet: Compilation failure: Compilation failure:

[ERROR] C:\Users\username\workspace\parent-sci2\sci2\plugins\normal_plugins\edu.iu.sci2.visualization.bipartitenet\src\edu\iu\sci2\visualization\bipartitenet\model\Node.java:[30,0]

[ERROR] static final Function<String,Double> EXTRACT_DOUBLE_VALUE = new Function<String,Double>() {

[ERROR] ^^^^^^^^^^^^^^^^^^^^^^^^^

[ERROR] The blank final field FLOATING_POINT_NUMBER may not have been initialized

[ERROR] 1 problem (1 error)
The fix is to alter a source file, Node.java, which causes the issue:

1. Go to the directory of Node.java described in the error message 

1. In this case, it is located in the Eclipse workspace directory at parent-sci2\sci2\plugins\normal_plugins\edu.iu.sci2.visualization.bipartitenet\src\edu\iu\sci2\visualization\bipartitenet\model\
2. Open the Node.java file in a text editor

3. Remove the final keyword for the variable declaration EXTRACT_DOUBLE_VALUE
4. Save the file

At this point, attempt the Maven clean install again. It should now proceed without errors.

Tycho error and Compilation error: - The following error are resolved by using Eclipse luna 64 bit and upgrading Tycho version to 0.18.1 from 0.14.1

Tycho error:- 
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I resolved the above error by switching to eclipse luna 64 bit.

Compilation error:-

Exception in thread "main" java.lang.NoSuchMethodError: org.apache.maven.execution.MavenSession.getRepositorySession()Lorg/sonatype/aether/RepositorySystemSession;

To resolve the above error upgrade to tycho version 0.18.1
